CRAN Package Check Results for Package TCIU

Last updated on 2022-01-23 22:49:56 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2.0 31.97 453.78 485.75 OK
r-devel-linux-x86_64-debian-gcc 1.2.0 26.79 351.71 378.50 OK
r-devel-linux-x86_64-fedora-clang 1.2.0 585.87 NOTE
r-devel-linux-x86_64-fedora-gcc 1.2.0 590.56 OK
r-devel-windows-x86_64-new-UL 1.2.0 79.00 777.00 856.00 NOTE
r-devel-windows-x86_64-new-TK 1.2.0 ERROR
r-patched-linux-x86_64 1.2.0 30.98 447.04 478.02 OK
r-release-linux-x86_64 1.2.0 29.16 437.49 466.65 OK
r-release-macos-arm64 1.2.0 NOTE
r-release-macos-x86_64 1.2.0 WARN
r-release-windows-ix86+x86_64 1.2.0 70.00 1016.00 1086.00 NOTE
r-oldrel-macos-x86_64 1.2.0 WARN
r-oldrel-windows-ix86+x86_64 1.2.0 73.00 1022.00 1095.00 NOTE

Check Details

Version: 1.2.0
Check: package dependencies
Result: NOTE
    Imports includes 26 non-default packages.
    Importing from so many packages makes the package vulnerable to any of
    them becoming unavailable. Move as many as possible to Suggests and
    use conditionally.
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 1.2.0
Check: installed package size
Result: NOTE
     installed size is 12.4Mb
     sub-directories of 1Mb or more:
     doc 11.2Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-x86_64-new-UL, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64, r-oldrel-macos-x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.2.0
Check: package dependencies
Result: ERROR
    Package required but not available: 'ggpubr'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-new-TK

Version: 1.2.0
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building ‘tciu-LT-kimesurface.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    Loading required package: TCIU
    Loading required package: doParallel
    Loading required package: foreach
    Loading required package: iterators
    Loading required package: parallel
    Loading required package: cubature
    Loading required package: oro.nifti
    oro.nifti 0.11.0
    Loading required package: magrittr
    Loading required package: plotly
    Loading required package: ggplot2
    
    Attaching package: 'plotly'
    
    The following object is masked from 'package:ggplot2':
    
     last_plot
    
    The following object is masked from 'package:oro.nifti':
    
     slice
    
    The following object is masked from 'package:stats':
    
     filter
    
    The following object is masked from 'package:graphics':
    
     layout
    
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Quitting from lines 105-106 (tciu-LT-kimesurface.Rmd)
    Error: processing vignette 'tciu-LT-kimesurface.Rmd' failed with diagnostics:
    invalid 'path' argument
    --- failed re-building ‘tciu-LT-kimesurface.Rmd’
    
    --- re-building ‘tciu-fMRI-analytics.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    Loading required package: TCIU
    Loading required package: DT
    Loading required package: AnalyzeFMRI
    Loading required package: R.matlab
    R.matlab v3.6.2 (2018-09-26) successfully loaded. See ?R.matlab for help.
    
    Attaching package: 'R.matlab'
    
    The following objects are masked from 'package:base':
    
     getOption, isOpen
    
    Loading required package: fastICA
    Loading required package: tcltk
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Quitting from lines 133-134 (tciu-fMRI-analytics.Rmd)
    Error: processing vignette 'tciu-fMRI-analytics.Rmd' failed with diagnostics:
    invalid 'path' argument
    --- failed re-building ‘tciu-fMRI-analytics.Rmd’
    
    SUMMARY: processing the following files failed:
     ‘tciu-LT-kimesurface.Rmd’ ‘tciu-fMRI-analytics.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavors: r-release-macos-x86_64, r-oldrel-macos-x86_64